Why did you link me to this page?

We have detected that your web browser does not support current security standards. If you do not update your web browser you will start to lose access to secure online pages.

We will start blocking outdated web browsers in the future. This is an IT industry-wide change in order to maintain online security, other secure websites will perform the same change.

How do I prepare for this?

You simply need to ensure you are using an up-to-date web browser.

If the standard web browser on your Operating System does not have the required support as standard, you may be able to install an alternative web browser.

The latest versions of Chrome, Firefox and Opera are available for popular operating systems including mobile devices, and support the latest security standards. Here are their respective websites:




If you are not comfortable with this we advise that you ask someone you know and trust for assistance.

If this is a work device then we recommend that you contact your business's IT support.

Technical information

PCI DSS 3.1 state that the TLS 1.0 protocol will no longer be PCI compliant after 30 June 2018. TLS 1.0 will no longer be considered secure enough for PCI standards.

This means we cannot allow connections to our servers using TLS 1.0 protocol. A minimum of TLS 1.2 will be required to connect to sec.paymentexpress.com.

If you would like to read about this in more detail the PCI Standards Security Council have published a document on the matter. To read it click here.

Here is a webpage which allows you to see the security your web browser supports:


If it shows "Your client is using TLS 1.2" then your browser is ok for this change. If not, you need to update your operating system and/or web browser in order to access Payment Express services.

A guide for merchants can be found here.